Kindle
Own an old Kindle? You’ll want to update it by March 22 to ensure it can continue to connect to the Web and download new books. Amazon has released an emergency update for the 2012 Kindle Paperwhite as well as all previous models. If you miss it, you’ll encounter the next time you try to connect to the Kindle Store or sync your device with the cloud. Here’s a full list of the ebook readers that require this update: Kindle 1st generation (2007) Kindle 2nd generation (2009) Kindle DX 2nd generation (2009) Kindle Keyboard 3rd generation (2010) Kindle 4th generation…

This story continues at The Next Web
Source: The Next Web

LEAVE A REPLY

Please enter your comment!
Please enter your name here